Avid Media Access
MASTER GUIDE
Media Composer 6.5
Symphony 6.5
NewsCutter 10.5
Avid Editing Systems and AMA Features in Media Composer® 6.5.2 and later, Symphony® 6.5.2 and later, and NewsCutter® 10.5.2 and later

CONTENTS

INTRODUCTION............................................................................................................................................................................ 4
HOW TO MAKE AN AMA LINK.................................................................................................................................................... 9
AMA Settings................................................................................................................................................................................ 12
    AMA SETTINGS: BIN SETTINGS.......................................................................................................................... 13
    AMA SETTINGS: QUALITY........................................................................................................................................ 15
    AMA SETTINGS: VOLUME MOUNTING .................................................................................................................. 16
    AMA SETTINGS: LINK OPTIONS .................................................................................................................... 17
    REVIEW: AMA Linking Examples....................................................................................................................... 21
VIRTUAL VOLUMES: QUESTIONS AND ANSWERS.................................................................................................................. 23
MODIFYING AMA CLIPS............................................................................................................................................................. 26
    Field Motion Selection............................................................................................................................................. 26
    Source Settings...................................................................................................................................................... 27
    QuickTime Gamma Issue....................................................................................................................................... 29
    Automatic Aspect Ratio Correction.................................................................................................................. 30
    Audio Track Display Format................................................................................................................................ 32
AMA FILE EXPORT...................................................................................................................................................................... 35
WORKING WITH LARGE NUMBERS OF CLIPS.......................................................................................................................... 37
COPYING AMA MEDIA INTO AVID STORAGE.......................................................................................................................... 39
CONSOLIDATING AND TRANSCODING INTO AVID STORAGE................................................................................................. 43
AMA ONLINE – OFFLINE WORKFLOW.................................................................................................................................... 45
AMA LINKING VS IMPORTING CLIPS..................................................................................................................................... 48
AMA VOLUMES ON NETWORKS.................................................................................................................................................. 49
MORE SAMPLE AMA WORKFLOWS........................................................................................................................................ 51
AS-02 BUNDLE SUPPORT WITH AMA....................................................................................................................................... 56
TROUBLESHOOTING AMA.............................................................................................................................................................. 65
MISCELLANEOUS......................................................................................................................................................................... 69
APPENDIX A: NATIVE AND NON-NATIVE CODECS.................................................................................................................. 70
APPENDIX B: TERMS DEFINED...................................................................................................................................................... 72
INTRODUCTION

AMA stands for Avid Media Access. This technology—featured in Media Composer, Symphony, and NewsCutter software—enables you to integrate file-based media into your editing workflow quickly and easily. Unlike tape-based projects, in which you’d capture your video from tape to bring the footage into an NLE, file-based formats don’t require you to capture or import material to begin editing it.

With AMA-supported file formats, such as RED, Apple ProRes, AVCHD, P2 and XDCAM, you may link to files without having to perform a separate import or ingest step.

So what are AMA’s benefits?

• AMA linking is faster than capturing or importing the material—you get almost instant access to your footage
• Project clips may take up less drive space because you’re not required to make a second copy of what already exists in a file
• You can play back video formats not natively supported by Avid editing systems; for example, you can simply download and install the Canon XF AMA plug-in to play back Canon XF video footage in Media Composer—something not possible without using this plug-in
• You can manage your media outside of the Avid editing environment—you can create your own folders and organize your media any way you like
• AMA supports and displays more metadata about each clip than what’s available using other methods, such as Import

The purpose of this guide is to give you an overview of AMA (Avid Media Access), show you how to use it, and introduce you to more of its advanced workflows. For specifics about working with each of the media formats AMA supports, such as RED or AVCHD, please refer to the supplemental workflow guides available on the Avid AMA webpages (www.avid.com/ama).

Please be sure to also review your other Avid documentation, including the User Guides, any Read Me guides, release notes for the version of software you’re using, and the in-application Help guides. And refer to the AMA website at www.avid.com/ama for the latest information and AMA plug-in downloads from various manufacturers.
AMA is a plug-in-based technology

Because AMA is based on software plug-ins, not all of the media formats described in this guide will be available when you first install your Avid editing software—whether that’s Media Composer, Symphony, or NewsCutter. Your default installation includes the QuickTime AMA plug-in, MXF Plugin, Sphere plugin and the AS-02 plugin. These were created by Avid. All other plug-ins are available as optional downloads from the appropriate manufacturer’s website (accessible through the Avid AMA webpages). Just download and install what you need according to your projects at hand. This enables each manufacturer to keep their plug-ins up to date, and you don’t have to wait for the next release of your Avid software to take advantage of the manufacturer’s updates. You can install and update plug-ins as desired.

To download AMA plug-ins, visit the Avid AMA webpage at www.avid.com/ama, select the tab labeled plug-ins, and find links to the various AMA plugins.

Supported formats

As we mentioned above, AMA is a plug-in architecture, so manufacturers have the flexibility—and capability—to add media formats and update their plug-ins at almost any time. Avid’s current list of supported media formats is extensive, and the list of available AMA plug-ins is constantly expanding. Here’s a current list of available AMA plug-ins at the time of this guide’s publishing:

- AVCHD (Sony NXCAM, Panasonic AVCCAM, Canon VIXIA)
- Canon XF (Canon XF-Series)
- GFCAM (Ikegami GFCAM)
- MXF (ARRI ALEXA OP1a files—not OP-Atom directly) (MXF Plugin also required to support CANON XF plugin)
- P2 (Panasonic P2, DVC PRO HD, AVC-Intra)
- QuickTime (Apple ProRes, Canon 5D/7D movies, JVC ProHD QT)
- RED (RED ONE, RED EPIC)
- SONY HDCAM SR (HDCAM SR, SQ, and Lite)
- SONY XDCAM (Sony XDCAM, XDCAM HD, XDCAM EX, JVC ProHD MXF)

AMA is a powerful extension of the Media Composer family. For fast access, immediate editing, full metadata, short form editorial, conservation of drive space, and easy external management, it offers an excellent solution!
What plug-ins are installed?

To determine which plug-ins are installed in your editing system, use this simple console command to get the AMA report. From the Tools menu in your editing software, select **TOOLS > CONSOLE** to call up the console window. At the very bottom of the window type in this command:

```
AMA_LISTPLUGINS
```

You’ll see a report similar to the following:

<table>
<thead>
<tr>
<th>AMA PLUG-IN NAME</th>
<th>COMPANY NAME</th>
<th>VERSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sphere (5330 1.0.5399733)</td>
<td>Avid Technology, Inc.</td>
<td>1.0</td>
</tr>
<tr>
<td>AS-02 Plug-In</td>
<td>Avid Technology, Inc.</td>
<td>1.0</td>
</tr>
<tr>
<td>MSP_MXF Plug-In</td>
<td>Avid Technology, Inc.</td>
<td>1.7</td>
</tr>
<tr>
<td>QuickTime Plug-In</td>
<td>Avid Technology, Inc.</td>
<td>1.2</td>
</tr>
</tbody>
</table>

We see above that the default QuickTime plug-in from Avid is installed. If you install, say, the Sony XDCAM plug-in and repeat the command, you’ll see this list grow to this:

<table>
<thead>
<tr>
<th>AMA PLUG-IN NAME</th>
<th>COMPANY NAME</th>
<th>VERSION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sphere (5330 1.0.5399733)</td>
<td>Avid Technology, Inc.</td>
<td>1.0</td>
</tr>
<tr>
<td>AS-02 Plug-In</td>
<td>Avid Technology, Inc.</td>
<td>1.0</td>
</tr>
<tr>
<td>MSP_MXF Plug-In</td>
<td>Avid Technology, Inc.</td>
<td>1.7</td>
</tr>
<tr>
<td>QuickTime Plug-In</td>
<td>Avid Technology, Inc.</td>
<td>1.2</td>
</tr>
<tr>
<td>MSP_SonyXDCAMEXMP4_64bit</td>
<td>Sony Corporation</td>
<td>1.5007</td>
</tr>
<tr>
<td>MVP_SonyXDCAMEX_64bit</td>
<td>Sony Corporation</td>
<td>1.5007</td>
</tr>
<tr>
<td>MVP_MSP_SonyXDCAM_64-bit</td>
<td>Sony Corporation</td>
<td>2.1005</td>
</tr>
</tbody>
</table>
Plug-in performance

Media Composer, Symphony, and NewsCutter all support many native Avid codecs. Avid designed resolutions such as 2:1, DNxHD, and many others as post-production codecs. These Avid codecs provide excellent quality, with exceptional playback performance. DNxHD in particular resists degradation during renders, making it an ideal choice for post-production. Please note however that AMA plug-in performance can vary, depending on the formats with which you’re working.

When manufacturers create a media format for a field camera, they may be more concerned about achieving high compression for longer recording times than they are about playback performance in an editing environment. This is the main difference between an acquisition format and an editorial format.

Also, some extremely high-quality media formats that have large frame sizes, such as those from RED, contain so much data that normal computers cannot adequately support edit-quality playback.

Finally, some storage media, such as XDCAM optical media, may not have the playback speed to satisfy your editing requirements.

If you are concerned about AMA performance due to media speed, such as when using optical discs, try copying your AMA-connected media to a faster storage medium, such as a local hard drive.

If you’re concerned about AMA performance due to codec performance or media file size, you might want to transcode an AMA media format into a native Avid codec. Transcoding AMA footage is covered in detail later. For most AMA media formats, transcoding is not required, and you can begin editing immediately after linking to it.

Some Avid native resolutions

- DV 25 411
- DV 50
- 10:1m
- 4:1m
- 15:1s
- 4:1s
- 2:1s
- 20:1
- 10:1
- 3:1
- 2:1
- MPEG 40
- MPEG 50
- 1:1
- 1:1 10b
- DNxHD 36
- DNxHD 100
- DNxHD 115
- DNxHD 145
- DNxHD-TR 145 MXF
- DNxHD 175
- DNxHD 220
- DNxHD 220 X
- DNxHD 444
Avid native codecs offer the best performance on Avid editing systems. These are the codecs designed by Avid for the high demands of post-production speed and quality. There are some cameras and devices that record directly into Avid DNxHD® format, eliminating the need to transcode the footage at all.

For more information on which AMA formats are native to Avid editing systems, please see the chart in Appendix A. You can also refer to the Supported Formats Matrix on the Avid Knowledge Base. Search there for Supported Formats to find this document.

Even with the availability of AMA, there are some advantages to transcoding or consolidating media into Avid formats onto Avid storage devices:

- Get better editing performance
- Gain centralized management of your media through the Media Tool (standalone) or the Avid Access application (in an Interplay-shared storage environment)
- Easily share media stored in an Avid structure and format

When should I use AMA?

Here are the four typical ways to use AMA:

- To access footage for your edit session, replacing Importing and linear Ingesting
- To quickly browse the contents of a media device without needing to import
- To view the contents of a media device in order to select which portions to copy into your Avid storage environment
- To quickly access content stored on devices and in formats that are not native to your editing software; for example, AMA can be used to link to a QuickTime movie on your iPhone or to play an AVCHD file, which would normally require you to import

About AMA linking

To use footage in a project through AMA, you’ll essentially be creating links to the media to have the clips appear in your project. We’ll show you how to link to a file and how to link to a Volume. Just remember that a link to a file always places the files into the selected bin. Linking to a Volume allows you to choose where the media goes—either into a selected bin or into a new bin, which can be manually or automatically named. We will define a Volume, and a Virtual Volume, shortly

Linked media has a special Icon, visible on the three clips shown here. The icon looks like a chain link and reminds you that this media is being accessed as a link to the original files—they are not stored in an Avid-managed media folder.
HOW TO MAKE AN AMA LINK

There are three ways to create a link to AMA-supported media.

- Adjust your AMA settings to automatically link to removable media
- Manually link to a particular file or files using FILE > LINK TO AMA FILE(s)...
- Manually link to a Volume or Virtual Volume using FILE > LINK TO AMA VOLUME...

Automatically link to removable media

We will look at AMA settings in detail shortly. With automatic linking to AMA volumes is set to “On” in your Settings, inserting/attaching an original, supported media device (such as a P2 card or XDCAM disc reader) will enable your editing software to link to the clips on that media automatically. The linked clips will be placed in an existing or new bin (we’ll describe this shortly).

If you copy the contents of the removable media to the root of a hard drive, the drive will function similarly to the original media and automatically link. However, this is only good for one media copy per hard drive, so it’s not efficient. If you copy the media content in separate folders on the hard drive (creating Virtual Volumes), you will have the benefit of being able to organize them better for easier access.

When Automatic linking to AMA Volumes is enabled, connect a compatible media device (such as an XDCAM disc reader), to your computer. Your software will scan the new volume as it mounts and will then create and populate a bin with the clips representing the media on that device.

The clips in the bin will look different from other media—they’ll have a little chain link beside them to indicate they reference media. The clips will also be different in that they will contain more metadata than a regular clip. You can work with these clips as you would with other Avid media.

Manually link to an AMA-supported file

If you have a single file you wish to link to, such as a video on an iPhone, an MPEG file on a GoPro media card, or a single file on an XDCAM disc or hard drive, linking may be done from the File menu. You can link to a single file or a few files instead of an entire directory full of files. Choose FILE > LINK TO AMA FILE(s)... and then navigate to the file path to select the file or files for linking. You will also find this option in the bin context menu.

Some formats, such as QuickTime, XDCAM, and AVCHD, will perform file linking because the media for the clip is contained in a single file. Other formats, such as Sony XDCAM EX and Canon XF video, save the video, audio, and metadata in separate files, so file linking will not work on these types of formats.
Manually link to an AMA-supported volume

AMA also supports the concept of a “Virtual Volume.” A Virtual Volume is a copy of your original media stored in a directory on a hard drive. This copy can be made without any special software or procedures—just copy the card/disc/device contents to a folder on a hard drive and you have a Virtual Volume.

You can have many Virtual Volumes in many different directories on the same hard drive. If you have a Virtual Volume, you can have AMA recognize that copy of your media as if it were the original recorded media. You’ll be able to access this media, edit it, and perform any other functions with the media copy that you’re able to do with the original media.

For card-based formats, this is important because you’ll want to eventually reuse the cards. Simply copy your cards’ contents (all of the content, including every file and directory!) to separate directories for each card.

For optical media such as XDCAM, copying the disc to a hard drive as a Virtual Volume will increase editing performance, as the hard drive will be much faster than the optical disc. Remember to then REFORMAT the removable media, not just delete its contents, so the next time it is used the Volume has a unique ID and is not a duplicate of what has already been ingested.

To perform a link to a Virtual Volume, from the File menu, choose FILE > LINK TO AMA VOLUME… and navigate to the folder containing the media image.

XDCAM and P2 Legacy Menu Support

Before the AMA feature was introduced, Avid editing products supported P2 and XDCAM volumes directly through a set of menu items which are no longer normally required. These menu items are now normally disabled. Specifically, the File menu will not have the IMPORT XDCAM PROXY or IMPORT P2 options visible.

If for some reason you required these legacy menu items, they can be turned back on using the AMA settings, described next.
AMA Settings

With so many different users of AMA not everyone will want the feature to behave the same way, so we can custom tailor some aspects of AMA behaviour. This is done by adjusting your AMA Settings. These settings are found in the SETTINGS tab of your project window, and there are four AMA settings tabs:

**BIN SETTINGS** - When Linking to a volume, you choose if its clips appear in the selected bin or a new bin. If you choose a new bin, this setting allows you to choose what the name of that bin will be.

**QUALITY** - With a format such as XDCAM where proxy video and audio are present, you have the choice of linking and consolidating to the high res or low res media.

**VOLUME MOUNTING** - Choose if a volume mounts automatically when plugged into your computer, if a reused volume is checked for changes, and if older legacy import menus are available.

**LINK OPTIONS** - Choose how the audio on a linked volume is portrayed in the editing system, as Mono, Stereo, 5.1 or 7.1 sound.

**AMA SETTINGS: BIN SETTINGS**

Where do the linked clips go?

When AMA scans media, you can have it create a new bin to show your clips or deposit the clips into the currently selected bin. This doesn't involve copying or moving any of the actual media—rather AMA will create and store link references to the media (clips) in the bins, which are then used to access the media in their original location.

The top option (USE ACTIVE BIN) scans AMA clips and places links into the currently selected bin.

The bottom option (CREATE A NEW BIN) places clips into a new bin, which will be created using one of the following three naming options:

**Default bin naming convention:** The new bin receives the name of your project with a number appended to it. This is the same convention for bin naming that is used when you create a new bin manually.

**Volume name:** The name assigned to the removable media (disc, card) is used for the bin name—or for a Virtual Volume, the name of the containing drive is used as the bin name.

**Specify bin name:** Enter (ahead of time) the name of your desired target bin. If a bin with this name doesn’t exist, it will be created for you. If a bin with this name does exist, the new AMA clips will be placed into that existing bin. Even if the bin is closed, the bin opens and the new AMA clips will be placed inside.
For most, the “CREATE A NEW BIN” option with “VOLUME NAME” selected is a good choice, and it is the default. This conveniently places the contents of each media volume into its own bin, with the name of the media volume (assuming you’ve given it a name) as the bin name. This makes it easy to find and reconnect to the volume again, if required.

**Can I rename the bin?**

Your bin can be renamed, and AMA will find and re-link to the original clip sources when you connect to the original removable media.

If your AMA setting for bin naming is set to name the bin based on the volume name, reinserting the media will open this bin and reconnect the clips. If you rename this bin, AMA will not be able to find it and will instead create a new bin with the original volume name and populate it with clips, resulting in a duplicate bin. While this won’t alter your edit, it could create multiple copies of multiple bins, thus cluttering up your editing environment and making it more difficult to find the material you need.

To avoid the creation of duplicate bins when reinserting media, select the option to create a new bin based on volume name in your AMA settings, and avoid renaming bins. Alternatively, you might scan clips into the selected bin to avoid creating new ones.

**Can I rename the clips?**

Should you end up with a bin full of clips with the manufacturer’s generic default name, you can rename the clips without causing any linking problems. In a later section of this document, we’ll show you how to bulk rename clips in one shot.

If you do rename a clip, you can display the original clip name in your bin by displaying the column heading named SOURCE FILE. The location of the original clip is displayed in a column named SOURCE PATH. If your media is disconnected or unavailable, the Source Path will show its last location.

**What happens when I remove my media?**

When you remove/detach a media device from your computer, your clips go offline, and the DRIVE column in your bin goes blank.
AMA SETTINGS: QUALITY
How good do my clips look?

When working with a format like XDCAM, the recording exists both as a high resolution recording and as a low resolution (proxy) recording. This setting allows you to specify when you AMA link if you want to link to LOW or HIGH resolution media for Video and Audio, and make a similar choice when you are consolidating.

As an example of how this could be used, there is an offline workflow which starts by editing with AMA clips linked to low resolution video, and high resolution audio. When the edit is done, you relink to the original media and consolidate your sequence with the settings set to high resolution to create a high resolution copy of your edit.

Please note linking to the PROXY audio is not supported, which is why these options are greyed out.

AMA SETTINGS: VOLUME MOUNTING
Manage Automatic AMA-linking to Volumes

Controlling AMA Volume Mounting behaviour is done through the AMA settings, on the third tab shown here. There are three options you can enable or disable:

Enable Legacy P2 import
Enable Legacy XDCAM import

These are normally OFF as the legacy import workflow they support is very rare today. Turn this ON if you must enable the legacy P2 and XDCAM import menu items. Note this disables the respective AMA plugins, and any currently linked AMA content using these plugins will go OFFLINE.

Automatically AMA-Link to volumes

When turned ON, if you connect a drive to your computer it will be checked to see if it is an AMA Volume, and if it is it will automatically be mounted. Media Composer, Symphony, and NewsCutter all come with this automatic mounting feature turned on.

When mounting previously mounted volumes, do not check for modifications to the volume.
When you remount a volume you have used before, you can decide if you want the volume to just be mounted, or mounted and then rescanned to see if any additions to the volume have been made.

This option is NOT checked by default, so previously mounted volumes are rescanned for changes when they are mounted again. With some formats, such as those using optical media, this rescan can take a long time. In this case, if you don’t want the rescan to be performed place a checkmark here to mount the volume without a check for changes.

**AMA SETTINGS: LINK OPTIONS**

How does my Audio appear in the Clips?

An audio track can contain several ‘voices’. For example, a Stereo track is a single track in the clip, but contains two separate signals, a Left and a Right recording. We don’t refer to the separate left and the right recordings as “tracks inside the Stereo track”, but as the two Voices of the Stereo track.

Clips themselves may contain many different numbers of voices, and these can be displayed by the operator in a variety of ways. A clip with four voices could be displayed in the timeline as four discrete tracks, or as two stereo tracks. We need to differentiate between the number of source signals in a clip (voices), and how they are represented on the clip (tracks).

This setting allows you to define the AMA link as displaying the audio tracks which are present in the file as discrete tracks, or half the number of tracks which contain stereo pairs, or even single tracks which contain 5.1 (6) or 7.1 (8) audio tracks.

We choose here how we want the files audio recordings to appear in the Avid clip tracks. Note there is no physical difference in the recordings, we are just displaying the recordings as stereo pairs or as single discrete tracks. In fact we can change from one representation of the sound in the clip to another at will using the Avid’s MODIFY command.

Remember not to confuse Voices with the number of tracks in the Avid Clip (and Timeline). Each Avid clip’s individual track may have several voices now.
What happens when I reinsert my removable media?

When you reinsert your removable media, what happens depends on two of your AMA settings.

If **Automatically AMA-Link to Volumes** is not checked, nothing happens. This option must be checked to allow automatic AMA linking. If it is not checked, you can still use the file menu option Link to AMA Volume… to connect to the volume manually.

If the option **When mounting previously mounted volumes, do not check for modifications to the volume** is selected, your volume will not be checked to see if any new clips have been added to the volume since it was last used. This will allow it to mount more quickly, but it will not display any new clips added to the media since its last use.

If you leave this option unchecked, your new volume will be rescanned to look for new clips. This will take some extra time, particularly when working with optical media which is quite slow to read.

If you have the “**When mounting previously mounted volumes, do not check for modifications to the volume**” checkbox selected, the media will always be rescanned. If the checkbox isn’t selected, the media will only be rescanned if its contents have changed.

Where do these re-linked clips on my volume appear?

When a volume is automatically re-linked, or you re-link to a Virtual Volume, you have control over how the clips appear in your project. They could pop into the selected (active) bin, they could create a new bin, or open the original bin in which they were stored. This depends on your AMA settings, the first tab labelled BINS.

**USE ACTIVE BIN selected:**

Your clips will appear in the currently selected bin. If you then open the original bin with the AMA clips, they will also be linked, but you will have two copies of the clips.
CREATE A NEW BIN selected:

You have three choices here:

- **Bin Named with Default Naming Convention:** A new bin is created each time the media is inserted and given the next available default bin name.

- **Volume Name:** If there is a bin with the same name as the removable media, the bin is opened. The contents of the removable media are compared with this bin, and any new clips are added to the bin. If there is no bin with the same name as the media (either the media or the bin have been renamed), then a new bin is created and populated.

- **Specify Bin Name:** If there is a bin with the user-specified bin name, this bin opens. The contents of the removable media are compared with this bin, and any new clips are added to the bin. If there is no bin with the user-specified bin name (the bin has been renamed), then a new bin is created.

With this setting, be aware that renaming a bin or renaming the removable media after the initial AMA scan has consequences. When that media is reconnected, it may not be able to find the originally named AMA bin containing its clips, and so the system creates a new bin and creates new clips for the AMA linked material again. Even if this happens, your original clips will be relinked as well.

What happens when I deselect this Volume Mounting option?

When deselected, the reinserted media isn’t always rescanned. Your software checks the modification date of the media, and if anything has changed since the last time you used the media in this project, the media is scanned again. If the modification date has not changed, the media is not scanned again, and the clips are linked to any existing AMA clips that are present in the project.

If there have been no changes to the media, this setting is the fastest one to use when remounting previously scanned volumes.

When reconnecting removable media, it’s best to wait for the system to scan the media. It may take a few seconds for the media to be read and linked to the AMA clips in your bins. Be patient or your clips may report being “offline” if you try and work with the clip immediately after mounting the drive.
How do I relink to my media if I move it?

If your media is on the original manufacturer’s disc or card, insert the original media and your software should find the original recordings and behave as described.

However, you will need to relink your media if you move the location of your AMA linked files or Virtual Volume. If you’ve copied media from its original location to another storage device, you can reconnect clips to the moved media by choosing FILE > LINK TO AMA VOLUME.

If you have individual files you want to relink to, choose Link to AMA File(s) again. If the files contain the proper identifying information, they will relink. XDCAM and AVCCAM are examples of these formats.

If the files are QuickTime movies, a new clip will be created and the original one will remain “offline.” You can avoid this situation with QuickTime movies by taking another approach. If you want to relink to QuickTime files in a new location or with a different name, select that clips in the bin, then right-click and choose Relink to AMA File(s). This file relinking is only available for QuickTime movies, and is described in more detail in the AMA QUICKTIME GUIDE at www.avid.com/ama.

REVIEW: AMA Linking Examples

In the following examples, let’s assume that your Automatic AMA-link setting is “On,” you have the correct AMA plug-ins installed from the manufacturers (where appropriate), and you have the drivers for these manufacturers’ cards or disc readers installed. Here’s what to do in these scenarios…

EXAMPLE 1: AUTOMATIC LINKING

On your Media Composer system, you already have a few images of airplanes in a bin named “Airport” in your project. You receive an XDCAM disc of new footage. You want to add the new clips on the XDCAM disc to this existing “Airport” bin using AMA. To do this:

1. First, make sure your AMA settings are set to place the files in the currently selected bin—open the AMA Settings, select the first tab, select the USE ACTIVE BIN checkbox, and then close the settings.
2. Select the bin in which you want the clips to be created (in this case, Airport).
3. With your Sony disc reader connected to your Media Composer system, insert the XDCAM disc into the reader.
4. Media Composer automatically senses the disc, begins reading it, creates new clips for the media on the disc, and then deposits them into the selected bin, linking them.
In this case, the XDCAM disc must be present for the clip to play. If you remove the disc, the clip will be offline. Sony’s XDCAM format uses an optical disc technology (similar to DVD and Blu-ray) for its recording. This media is often judged to be too slow for editing operations. Your options include copying the disc to a hard drive and use this copy for editing (a Virtual Volume). Alternatively, you can copy (consolidate or transcode) clips on an AMA-linked disc onto faster Avid local storage.

EXAMPLE 2: MANUALLY LINK TO A FILE

You receive a QuickTime movie on a DVD-ROM from your client. This movie will become the opening for one of your client’s programs, and is located in a folder on the disc with many other movies. You want to link to this file, but not to all of the other movies on the disc. To do this:

1. Open and select the bin in which you want the movie clip to appear.
2. Choose FILE > LINK TO AMA FILE(s)…, navigate to and select the desired QuickTime movie, and click OK.
3. The file appears in the bin as a linked file. You load and play the file to confirm it’s the right one, but notice the playback performance from the DVD is very poor.
4. You then copy the QuickTime movie off of the disc onto your Avid storage. However, the original movie is encoded using the Animation codec, which is not a codec native to Media Composer, so consolidate will not work. Because of this, you copy the movie onto Avid storage using the Transcode command, which copies it and simultaneously converts the file into an Avid supported native codec—in this case, you choose Avid’s DNxHD 145 codec to maintain the quality and provide improved playback performance over the original non-Avid codec.

Now the DVD-ROM does not need to be connected to edit with the clip.

EXAMPLE 3: MANUALLY LINK TO A VIRTUAL VOLUME

You receive a P2 card containing AVC-Intra media. Production needs the card back for reuse the following day, so you do this:

1. Copy the entire contents of the card to a local drive on your Media Composer system. In addition, you create a backup copy of the card on a separate network drive for safety.
2. Check your AMA Settings > BIN tab to determine where the AMA clips will be stored. Choose to create a new bin based on Volume name.
3. In Media Composer, choose FILE > LINK TO AMA VOLUME and navigate to the directory containing the card copy (the Virtual Volume) on your local storage drive. Select the directory (not its contents) and click OK.
4. AMA creates a bin named after the P2 volume and populates it with clips for the footage on the Virtual Volume. Since the Virtual Volume is on a fast, local storage drive, you can directly use the material for editorial. You can then return the P2 card to production for erasure and reuse.
5. Let’s say you now want to perform additional editing at a remote site, so you’ll need to make copies of the P2 media on a small portable drive that you can take offsite. Select the clips in the bin and transcode them from P2 (AVC-Intra) into DNxHD 36, so they all fit on the smaller drive.

VIRTUAL VOLUMES: QUESTIONS AND ANSWERS

Earlier, we explained that a Virtual Volume was essentially a copy of all the media on your recording device, stored in a folder on a hard drive.

When creating Virtual Volumes, be certain that all of the folders involved in the AMA linking only contain alphanumeric characters. Using slashes (/), periods, or any other special characters in any of the folder names may cause issues with AMA. Also, if you’re using a Mac, be sure that no two drives/volumes have the same name, or AMA won’t be able to find the correct volumes.

Virtual Volume Mounting:

How do I quickly mount multiple Virtual Volumes?

If you wish to access media spread across multiple Virtual Volumes at the same time, place all of the card copies in subfolders within the same folder (we’re using P2 cards in our example). Then choose FILE > LINK TO AMA VOLUME and indicate the parent folder—all of the P2 cards in that folder will appear as bins automatically. This diagram might help clarify this.

Each folder represents a location to which an image of a P2 card has been copied. When you choose FILE > LINK TO AMA VOLUME, the following occurs:

- If you access “P2 Card 1 contents,” only content from the P2 Card 1 appears
- If you access “Parent Folder,” then content from all four P2 cards—1 to 4—appears
- If you access “P2 Card 5,” only content from the P2 Card 5 appears
Virtual Volume Mounting:
Support for deeper folder structures

With the popularity of stereoscopic 3D programming, the latest versions of Media Composer, Symphony, and NewsCutter all have new capabilities that enable easy access to pairs of stereoscopic files. A recording from a stereoscopic 3D camera rig produces two separate sets of files, one for each eye (Virtual Volumes). You will want to store the pairs of files in the same folder, and this parent folder itself will be one of many on a hard drive.

These latest software releases now scan down two folder levels for Virtual Volumes, and can link folders containing multiple Virtual Volumes, one for each eye. Using the above folder structure as an example, linking to the DAILY folder will scan down two folder levels, and mount six volumes for that day.

While stereoscopic 3D editing has been the motivation for this feature, you can also use this capability on non-3D projects to organize your Virtual Volumes into deeper folder structures.

Virtual Volume Mounting:
Linking to multiple Virtual Volumes: naming options

When you scan multiple Virtual Volumes of content simultaneously using FILE > LINK TO AMA VOLUME, a dialog box appears. It asks you where you want to place the contents of these Virtual Volumes within the bin structure of your project.

Since it’s possible to bring multiple Virtual Volumes in at once, you can choose to bring all of the clips into one bin, or keep the clips in separate bins based on the individual folders.
While most choices are obvious, it is worth noting that “Multiple Bins Based On Subfolders” names the bin with the same name you gave the subfolder into which you copied the media. This could be the most useful option for most users. Here’s a description of what each dialog choice does.

**SINGLE BIN BASED ON SELECTED FOLDER**: Places all clips from the selected Virtual Volume and those two levels deep into a single bin, named after the top-most folder. This is a good way to get clips from multiple volumes into a single bin quickly. Plan your folder structure to take advantage of this and it will speed things up for you!

**SINGLE BIN NAMED ____**: As above, all contents go into a single bin, but it will be given the custom name you type in the field.

**BIN(S) BASED ON CURRENT AMA SETTINGS**: In your AMA Settings, on the BIN tab you can choose three options for naming a new bin. This choice defers to the selection made for new bin naming there.

**BIN(S) BASED ON SUBFOLDERS**: Places the contents of the selected Virtual Volume and those two levels deep each into their own bin named after the folder that contains the Virtual Volume contents.

**TOP BIN WINDOW**: Places the contents of the selected Virtual Volume and those two levels deep into the top-most bin (the one that currently covers all of the others), whether it’s selected or not.

If you have a parent folder with three Virtual Volumes, link to the parent folder and choose this option to have the contents of all three volumes appear in a single bin.

If you have a *parent folder* with three Virtual Volumes, link to the parent folder and choose this option to have the contents of all three Volumes appear in separate bins each with its own folder name.
MODIFYING AMA CLIPS

When you link to a clip using AMA, there are several aspects of the clip you can adjust.

- The clip may be Interlaced or Progressive, and you need a way to select how Media Composer interpolates the footage for playback
- The video levels may be “RGB” graphic levels or they may be “CCIR” or TV levels; you may need to switch between the two to find the correct setting for some clips.
- The aspect ratio of the clip may be 4x3 or 16x9, and your software may need guidance to identify this ratio correctly, so that it can apply automatic Aspect Ratio Correction if necessary

Field Motion Selection

When you link to a clip using AMA, your Avid editing software will make a best guess as to the Field Motion of the clip—either Interlaced, Progressive, or Progressive Strobe. While this will be a best guess, based on the file format and other factors, it could, in some cases, not play back as desired. If you notice any motion artifacts while playing back a clip (AMA or not), you may want to change these settings and view the clip again.

In the bin display, the FIELD MOTION column displays the current setting, but also provides a drop-down menu for each clip. Click on a clip’s current setting to see three other options and select an alternative setting.

The clip in the player will now play back with this setting, and on a proper broadcast display, you can now evaluate this alternate field motion. Please note that you are not likely to see any meaningful difference if viewing on a computer display, as computer monitors don’t display fields, so you won’t see these differences.

This alteration does NOT automatically change the field motion of shots already in a sequence, as this would be undesirable. If you do want these new adjustments to apply to the clips in a particular sequence:

1. Load the sequence in the timeline and select it.
2. Choose CLIP > REFRESH SEQUENCE > Motion Adapters/Timewarps.

This option is also available as a right click on a sequence in a bin.
Source Settings

This section refers to setting parameters that dictate how an AMA file is interpreted by your editing software. To make this adjustment, select an AMA linked clip, right-click on it, and choose Set Source Settings. This adjustment works for QuickTime movies and RED files only. With QuickTime movies, this setting is not available if the movie uses an Avid native codec, as described below.

In the case of an adjustable QuickTime file (such as a Canon QuickTime movie), you can choose to interpret it as RGB or TV (601/709) video levels. Files from most graphic programs, such as After Effects, are likely to be RGB; files from TV systems are likely to be 601 (NTSC)/709 (HD). The difference between these interpretations is, simply stated, how black the blacks are and how white the white is. If the contrast of a file seems excessive, or conversely, seems flat and compressed, this adjustment may be needed to apply the proper interpretation to the levels within the file. The correct setting is the one that interprets and displays the file correctly on your calibrated monitor.

In the case of QuickTime movies, this setting is only supported for QuickTime movies that were created with a non-Avid native codec, such as H.264, or the Animation codec. If the QuickTime file uses an Avid codec, the codec itself specifies the proper settings.

Notice that there’s a slider under the picture. Drag this slider to select a representative frame (one that has white and black in it).

The graphs below show the effect of the video level adjustment on a Canon QuickTime (.mov) file. To infer the correct setting, you’re generally looking for a frame where the levels appear between the two white bars (left and right) and fill as much of that range as possible.
Choose between the three settings in the GFX/Video Level drop-down menu, watching the image and the graph to infer the correct setting. Note that the sample file was correct to begin with, its levels falling within the white bars, which indicate where TV black and TV white occur.

For QuickTime, it’s ideal if the supplier of the file can tell you the levels that are present in the file. In this case, it will be easier for you to infer the correct setting. If they cannot, then you have to infer the correct setting from the visible image and the graph that is present. If you have external monitoring, use those instruments to assess the results and determine the correct levels.

RED files have many more settings and adjustments per clip. It’s also possible to use a RED RMD/RLX/RSX grading file for this clip through the provided drop-down menu.

QuickTime Gamma Issue

This is a situation often referred to in newsgroups where the video level of a QuickTime movie may appear incorrect when imported into your Avid system. The video may look washed out, or conversely, have too high a contrast.

The pixel levels in a file contain values from 0 to 255, but they can represent video levels from black to white, or they can represent levels from “super black” to “super white.” As we mentioned, the levels are not always known when you receive a file, such as a QuickTime .mov, so there is no way for your software to always get this correct.

When you import a .mov file, your Avid software uses the QuickTime engine to decode the file, which is often incorrect in its interpretations of the color space. On a Mac, the PERIAN QuickTime component is also well known for interpreting source files incorrectly. Once imported, it is difficult to change these incorrect interpretations.

With AMA, however, if you link to a QuickTime .mov that does not use an Avid codec, you can use the Source Settings to look at the linked movie in three different ways in order to find the correct interpretation for the file.
Our recommended method of handling non-Avid codec QuickTime movies is not to import them, instead:

1. Link to the QuickTime movie using AMA.
2. Adjust the source setting.
3. If desired, transcode the movie to Avid storage (don’t consolidate, even if the choice is available. Consolidate creates just a copy of the original file without your source settings adjustments).

Importing is not recommended for two reasons. First, there's the potential color level problem if you do not ensure the correct file interpretation is in force. The second reason is speed. Importing a QuickTime file can take as much as 5x longer than transcoding that file to Avid storage. Some of our test files took 2:30 minutes to import and convert, but only 30 seconds to transcode to DNxHD 145.

**Automatic Aspect Ratio Correction**

Changing the aspect ratio of media you work with is still a common task for editors. Many still deal with a mix of SD and HD content. In an SD 4x3 master, HD content looks anamorphic (squished). In an HD project, 4x3 SD legacy content looks stretched. These errors can be fixed by adding an effect found in the Reformat effect category. However, this must be added in the sequence on a clip-by-clip basis, and is more work than necessary.

As an alternative, you can identify the aspect ratio of a clip, and then specify how you want this clip to be reformatted if the aspect ratio of the clip doesn’t match the aspect ratio of the project. Your Avid software will then automatically apply aspect ratio correction to your clip when required. This means you don’t need to apply a Reformat effect every time you edit from a clip with a mismatched aspect ratio.

To set up automatic aspect ratio correction for a clip, you need to display two columns in your bin, **IMAGE ASPECT RATIO** and **REFORMAT**. These columns actually control the attributes of the clip—not just display them. To do this:

- Using the **IMAGE ASPECT RATIO** column, indicate what the format of the clip should be (16x9 or 4x3). Click in the column displaying the current aspect ratio and choose the correct one from the drop-down menu. If you can’t make a selection, it’s because none is needed. For example, HD footage in an HD project can only be 16:9.
- Using the **REFORMAT** column, click and select one of the four different ways to make your picture fit the project’s frame size when there is a mismatch.

Your choices are:

a. Stretch  
b. Center Crop  
c. Center Keep Size  
d. Pillarbox/Letterbox
You will see your clip in the Source monitor immediately reformat to match your instructions. Every time you edit from this clip, if required, it will now be displayed using your selected reformat options without you needing to add a REFORMAT effect.

This alteration does not automatically change the format of the clips already in a sequence. If you do want these new adjustments to apply to the clips in an existing sequence:

1. Load the sequence in the timeline and select it.
2. Choose CLIP > REFRESH SEQUENCE > REFORMAT OPTIONS.

This option is also available as a right click on a sequence in a bin. It is available with regular or AMA clips.

**Audio Track Display Format**

Media Composer, Symphony, and NewsCutter now support the designation of audio tracks in a clip as being Mono (discrete), Stereo, 5.1, or 7.1. Once you designate a set of tracks, they will be combined into one or more "multichannel" tracks for the clip.

We now speak of a recording as having Voices, and these can be displayed as different types of Media Composer tracks. A four track movie—ONE WITH four voices can appear as a clip with 4 discrete tracks, or as a clip with 2 stereo tracks. In each case the sound is the same, the difference is largely for operator convenience.

For example, you may designate a clip that contains six voices as being a 5.1 audio clip. The clip will appear to have a single track, and yet this track represents all six channels of audio. Similarly, a two-voice clip can be designated as a stereo clip, and it will appear with a single Stereo audio channel.

A track identified as “multichannel” is purely designed for user preference. In all cases, the media files are identical, and all that is different is how the tracks are viewed in the editing interface. For example, there is really no underlying difference between stereo and mono tracks. With music, for example, designating a clip as a stereo track will reduce the number of tracks in the timeline, and make level adjustment and filtering easier as the music is accessible as a single track.
DESIGNATING MULTICHANNEL TRACKS

You can initially designate tracks as Mono, Stereo, 5.1, or 7.1 at time of capture, import, or AMA linking.

In the AMA Settings dialog, select the Link Options tab and next to MULTICHANNEL AUDIO, click the EDIT button. You can select your multichannel interpretation for the clip here. Click on the button below the different tracks to assign your multichannel tracks.

This has no effect on clips already AMA linked in your bins, and only affects newly linked clips.

8 Audio channels configured as two tracks: one 5.1 track and one Stereo track

SWITCHING MULTICHANNEL TRACK DESIGNATIONS

You can freely change the characteristics of the audio voices in the clip between any of the multichannel options; for example, between Stereo or Mono. This does not change any edits already made in your sequence but changes how the clip will appear the next time you load it up in the Source monitor.

8 tracks assigned as 8, discrete channels

Switch track designations by right-clicking on the clip in your bin and choosing MODIFY > MULTICHANNEL AUDIO. From the drop-down menu, choose SET MULTICHANNEL AUDIO. Click on the button below the different track pairs to assign those tracks to the multichannel tracks of your choice.
TIMELINE AUDIO TRACKS

For the following discussion, we’ll use stereo audio pairs as our example, although all points also apply to 5.1 and 7.1 multichannel tracks as well.

In the timeline, multichannel tracks can only be edited onto a timeline track of the same type—stereo to stereo, and 5.1 to 5.1 for example. Here we see on the Source side, four stereo tracks; on the Recorder, we have two mono tracks and one stereo track. The four source stereo tracks can only be patched to recorder track three (one at a time, of course).

In this example, we see that A1 on the Source side is a stereo track, and is patched to A3 on the Record monitor, which is the only stereo track present on the record side, so the only option available for this patch.

When you create an audio track, you can now choose between four different types to support each of the multichannel options. If you choose CLIP > NEW AUDIO TRACK, you can choose Mono, Stereo, 5.1, or 7.1 as your audio track type. The shortcut for creating a mono track is still CONTROL/COMMAND + U, while stereo tracks have their own shortcut, SHIFT + CONTROL/COMMAND + U.

You cannot patch a mono signal to a stereo track, or vice-versa. An audio track will now display either one (mono) or two (stereo) small speakers to indicate its type. Surround sound tracks will display the text 5.1 or 7.1 beside their track number.

CHANGING SEQUENCE TRACKS

The multichannel tracks you have created in the sequence can be split into “mono” or discrete tracks at any time. You cannot, however, select multiple mono tracks in a sequence and combine them to form a multichannel (stereo, 5.1, or 7.1) track. In a timeline, you can alter STEREO to MONO, for example, but not the other way around. Stated another way, you can break a sequence multichannel track apart, but in a sequence, it is not possible to combine discrete tracks into a multichannel track.

To split all tracks in a sequence to mono, load the sequence into the timeline, right-click in the timeline, and choose SPLIT ALL TRACKS TO MONO. This option is also available in the Clip menu if you select the sequence in a bin.

To split a single track in a timeline to separate tracks, right-click on its track selector and choose SPLIT TRACK TO MONO.
AMA FILE EXPORT

The emphasis of AMA has often been on its linking capabilities to external files for editing. AMA plugins are also available to assist in exporting material from the editing system. AVID offers the option to export completed work back to manufacturers original volumes or to specific file formats.

For example, an edited show can be output to a manufacturers device, such as a Sony XDCAM ProDisc, or a Panasonic P2 card. This is done with a feature called EXPORT TO DEVICE and saves your work in XDCAM or P2 only. In other cases we can use an AMA plugin to export a file in a manufacturers file format to any destination we choose.

DEVICE EXPORT

A Device export involves more than just sending a compatible movie to the target media. Manufacturers devices have a very specific and unique structure, so the media must be deposited in the correct locations. There are also a variety of accompanying files on the media volumes which need to be updated – various indexes and sidecar files.

Avid AMA Device Export creates compatible media, but also deposits it on the manufacturers media in a fully compliant manner. This allows for easy distribution of content on various manufacturers media.

To perform an Export to an XDCAM or P2 device, right click on a Sequence or clip in the bin, and choose EXPORT TO DEVICE > P2 or EXPORT TO DEVICE > XDCAM. A dialogue box will appear for you to choose some basic export options. Fill this form out and click OK.

This feature works with Sequences and Clips. You may also choose single or multiple objects for export at once.

AMA FILE EXPORT

AMA FILE EXPORT allows you to export your clips or Sequences to a file using a manufacturers specific codec. While AVID’s classic EXPORT command offers a lot of options, these AMA FILE EXPORT choices are more specialized and industry specific. They are performed using a manufacturers AMA Export plugin which can be downloaded from their web site. Currently, Sony has available the HDCAM-SR plugin. This number of available Export plugins will grow as other manufacturers create plugins to allow media to be exported in their file formats.
As with a linking AMA plugin, the AMA File Export plugins will be displayed when you use the console command `ama_listplugins`. The Sony HDCAM-SR plugin appears as follows:

```plaintext
MVP_MSP_SonySRDeck_64bit Sony Corporation x.xx
```

The option to export a file in a manufacturer's specific codec using their plugin is called AMA FILE EXPORT and it is available in the context menu (Right Click/PC CONTROL + CLICK/MAC). You can use the context menu in the Source monitor, Record monitor or with one or more selected items in the bin.

The AMA FILE EXPORT dialogue will appear.

- **FILE TYPE:** Choose the plugin to use for this export from the dropdown menu.
- **USE MARKS:** Check this option to only export material between the mark IN and mark OUT points on the Clip or Sequence.
- **USE ENABLED TRACKS:** Only export those tracks which are enabled (turned ON) in the Clip or Sequence.
- **SET DIRECTORY:** Click to navigate to and select the destination for the exported file.
- **FILE NAME:** Edit or enter a new file name for the export.
- **QUALITY:** Select the desired Quality for the file.

### WORKING WITH LARGE NUMBERS OF CLIPS

When AMA linking to media from a field recorder, you may be faced with hundreds of separate clips on the card/disc. The tips below suggest some ways to make working with these clips easier.

**Make a sequence from the clips**

For each recording (card/disc), put your clips in a sequence and screen this sequence in the player to find your shots.

1. View your clips in Text mode.
2. Sort the clips by timecode, from earliest to latest.
3. Select all clips and drag them into an empty timeline.
4. Name the timeline with the disc/card name or something meaningful.
To work with this timeline:

1. Load the sequence into the player. This can only be done by dragging and dropping it there.
2. Scroll and park on a shot you are interested in.
3. Select Match Frame to load the original single clip into the player for easier scrolling and mark selection.

Jump from shot to shot

You can use the Fast-Forward (FFW) and Rewind (REW) buttons to jump from shot to shot. In NewsCutter, these are already assigned to the A and S keyboard keys.

In Media Composer and Symphony, you can also assign FFW and REW to your A and S keys, respectively, as follows:

1. Open your Keyboard diagram by navigating to your settings and double-clicking on the Keyboard setting.
2. Open your master list of buttons by choosing TOOLS > COMMAND PALETTE.
3. Select the Move tab in the Command palette. Drag and drop FFW and REW from the Command palette to the A and S keys on your keyboard setting.
4. In Composer settings, on the tab labelled FF REW, select “Stop At Markers” and “Ignore Track Lights.”

You should now be able to jump from shot to shot in your Source monitor with your A and S keys. These will also jump from cut to cut in your Sequence monitor.

Batch rename the clips

Having hundreds or thousands of clips from many projects, all with numbers as their names, makes working with shots and clean-up a bit difficult. No worries. You can batch rename clips after you AMA link to them. The names for a batch of clips will be identical, but at least now you won't have a large number of clips all named “C0001.” To do this:

1. Select all related clips that you would like to batch rename. Do this by displaying the column that shows thumbnails in your text display (choose BIN > HEADINGS and then choose FRAME).
2. Select the group of clips you want to rename.
3. Right-click on one of the existing names (not the column heading “NAME”) and choose “Set Name Column for selected clips...” to open the Set Name dialog. Enter a new name for this group of clips and click OK.

Each clip in the group receives the same new name. Still, having blocks of names like this is better for organization than having multiple clips from multiple discs/cards with the same default name.
COPYING AMA MEDIA INTO AVID STORAGE

What is Avid storage?

When we mention “Avid storage,” we’re referring to media drives to which you would normally digitize video and audio. These could be internal SATA drives on your workstation or external SCSI or SAS drives. ISIS 2000, 5000, and 7000 are Avid’s latest shared storage solutions.

In all cases, Avid storage is both fast and managed by your Avid editing application. Standalone systems use your software’s Media Tool. If you use Avid Interplay, it uses the Interplay Window and Avid Interplay Access for management. No matter what you use, all of the media is grouped in one location—the AVID MEDIAFILES folder (or folders).

Compared to playing footage directly from your AMA linked media device, housing clips in storage may offer faster access to more media, more streams of video, and centralized management. Since Avid storage only holds Avid native media, this material offers the best performance possible on an Avid editing system. Avid storage may also be shared with other users through ISIS and Interplay, whereas AMA linking is more of a tool for individual editing systems.

AMA on ISIS and Interplay

AMA works fine when the Virtual Volumes are on ISIS®; just remember that the media you link to is local to your machine, and other users cannot automatically see your AMA shots. While the AMA volumes may technically be in shared storage (on ISIS), they are standalone AMA volumes and not Interplay®-managed and shared media. If you create a timeline using AMA media on an ISIS drive, it will appear with offline media to other users.

This is why, in many Interplay environments AMA would be used to link to media, and all or part of it would be consolidated or transcoded into the shared storage environment, so all users can access the same shared storage media.

A bin that contains any linked clips will not check in to Interplay. Technically, the media for these clips is not available to all users automatically, so the clips serve no purpose being checked into Interplay. The consolidated or transcoded copies of these clips can be stored on shared storage workspaces, and can be checked in if they are in their own bin.

Dynamic Relink does not work with AMA clips unless you are working with Avid Sphere.
Why should I copy my media onto an Avid Storage device?

There are many reasons to copy media onto Avid storage.

- You only have one media player (a P2 card reader, for example) and many P2 cards; to access more than one P2 card at a time, you’ll need to copy media to common storage (copying media to Avid storage is one way to consolidate media from many sources into a single location)
- Avid storage is likely to be faster than accessing clips off of a media device connected by a FireWire or USB cable; this provides better performance during editing
- While you copy media onto an Avid storage device, the media can be transcoded into an Avid native codec (such as Avid DNxHD), which may perform better than some manufacturers’ codecs, and may be required by some AirSpeed playback servers
- Avid storage is centrally managed (by Media Tool or Interplay Window/Access)
- You need to make the media available to multiple users at the same time in a collaborative work environment
- You wish to have the security or RAID protection on an ISIS 5000/7000 system to protect your media assets

How do I copy my footage to Avid Storage?

There are three methods you can use to copy media centrally:

- File copy
- Consolidate
- Transcode

File copy

FILE IMPORT

You can perform a normal file import. When using the FILE > IMPORT command to bring in media from XDCAM and other natively supported formats, the media is essentially copied onto Avid storage, without any reprocessing or degradation. These are the formats that your Avid software can handle natively, and do not need to be converted on import. They import as quickly as they can be copied over, and we say that these formats “fast import” into the system. For a complete list of Avid native formats that support fast import, see Appendix A. Also, see the section on AMA LINKING vs. IMPORTING for a discussion on the issues related to using imported media vs. AMA linked media.

THIRD-PARTY APPLICATIONS

Some third-party software will deliver properly wrapped MXF files directly into an Avid storage folder (Avid MediaFiles folder), and in an Avid Interplay environment, check that new clip in. Companies such as NL Tek, MOG Solutions, Quadrus, and Telestream offer solutions of this type. Field recorders are also available from companies such as AJA, Blackmagic Design, CineDeck, Codex Digital, and Atomos, which will perform the original recording in an Avid native format.
Consolidate

Consolidate is the Avid copy command, and it transfers media to an Avid storage device. From the menu, choose CLIP > CONSOLIDATE / TRANSCODE.

For example, you could use AMA to pre-screen an XDCAM disc's contents and create a sequence containing the media you wish to transfer to Avid storage. Consolidate transfers only the media present in the sequence into Avid Storage from the original disc. To transfer entire clips, select the individual clips from the bin and Consolidate.

Not all media formats can be consolidated. Only those formats that Avid editing systems support natively can be copied directly onto Avid storage. If you receive an error while trying to perform a Consolidate with your media, use the Transcode option instead. This will convert the media into an Avid native format while being copied. Appendix A shows which formats Media Composer, Symphony, and NewsCutter support natively.

Transcode

Transcode is similar to Consolidate in that it's a copy command. The difference is Transcode can change the format of the media during the transfer. For example, you could change the sample rate or bit depth of the audio, as well as the codec used for the video.

If an AMA linked volume is not supported natively, such as if it contained RED, Sony HDCAM SR, or AVCHD video, you must transcode it to store it on an Avid storage system. You could transcode RED into DNxHD as it copies into Avid storage, for example.

Transcode is often used to convert video to a lower quality, so you can use the clips in an offline workflow (not to be confused with Media Offline). You can edit footage using the low-resolution media, then relink to the higher resolution original clips when complete. You might also transcode to convert incoming media to a broadcast facility’s common format.

CONSOLIDATING AND TRANSCODING INTO AVID STORAGE

You’ve seen that Consolidate can be thought of as your Avid editing system’s Copy command, simply moving media into an Avid storage device without major alteration.

The following operations can be performed on clips, subclips, or sequences. Begin by AMA linking to your media device, then selecting one or all of the clips, and choose CLIP > CONSOLIDATE/TRANSCODE.

NOT ALL MEDIA WILL CONSOLIDATE

Media stored in your Avid MediaFiles folder offers great editing performance, fast rendering, quick access, and more. But Avid storage is a protected world—you cannot place just any media there.
Avid storage is designed for Avid native file formats. You can only copy (consolidate) these native formats into the editing system. These natively supported formats include XDCAM, XDCAM-EX, XDCAM-DV, Canon XF, P2, GFCAM, Apple ProRes, and many QuickTime formats which contain compatible Essence within them.

If you try to consolidate a file with a non-native codec, such as a Canon .mov file, you will get an error message. While Canon .mov files are supported, they play back using the QuickTime plug-in.

This does not mean you can't move non-native files into Avid storage—you just need to change the files format as it copies into Avid storage. To do this, you will need to transcode it rather than consolidate it.

Consolidating media into Avid storage

1. If desired, create subclips or sequences that contain the media you would like to copy onto your Avid storage.
2. Select your clips, subclips, or sequences.
3. From the menu, choose CLIP > CONSOLIDATE / TRANSCODE.
4. Select the appropriate options in the resulting dialog. In most cases, all you really need to choose is the target drive for your copy.
5. Click the CONSOLIDATE button at the bottom of the dialog.

Transcoding media onto Avid storage drives

If you need your media in a different format, the Transcode command does exactly the same thing as Consolidate, except it enables you to change the media format during the copy process.

You can transcode clips, subclips, or sequences to transfer media onto Avid storage devices in a different format. For example, you might want to convert to Avid DNxHD for post production flexibility, or to a lower quality format to support an offline workflow.
To do this:

1. In your bin, select the clips, subclips, or sequences that contain the media you would like to transcode and copy to your Avid storage.

2. From the menu, choose CLIP > CONSOLIDATE / TRANSCODE.

3. Click the TRANSCODE button in the upper-left of the dialog box.

4. Fill out any option details in the resulting fields. In most cases, all you need to choose is the target drive for your copy and the video resolution.

5. Click the TRANSCODE button on the bottom-right of the dialog.

AMA ONLINE – OFFLINE WORKFLOW

Even with file-based workflows and large storage drive capacities, you may still have a need for a lower resolution offline editorial workflow, with a conform of the final program to high-resolution media (“rez up”) at the end. This may be required if you, say, have too much high-resolution media for the editing storage system, work with several clients using a system of limited bandwidth, or maybe you just want to take your laptop to Colorado and finish editing your epic in the relaxing confines of some getaway cabin.

AMA can be a part of this workflow. This approach enables you to avoid having to import a file before you transcode it, saving you time and storage space. In this situation, you end up with two copies of your media—one at low resolution in what we term Avid Storage, and one copy at high resolution, which remains on the original disc/card or in a Virtual Volume. You can relink an AMA clip (or a sequence containing AMA clips) to the media in either of these locations. To do this:

1. Use AMA to link to the original clips and note the location of the original media. To help you find the location of the clips later, you may want to enter the location of the clips in a data column such as “Disc Label.” We’ll describe this in detail shortly.

2. Transcode the original clips into lower resolution clips for editing by selecting the clips in the bin and choosing CLIP > CONSOLIDATE/TRANSCODE. Select your desired lower resolution and target drive, and then click the TRANSCODE button.

3. Edit your sequence using the low-resolution clips.

4. Relink to the original high resolution media and Consolidate/Transcode the sequence to high resolution by doing the following:
   a. Make a copy of the completed sequence and place it into a new, empty bin.
b. Remove all of the media for the show, so that the entire sequence is offline. This could simply mean disconnecting media drives, hiding your Avid MediaFiles folders, or indeed actually deleting media. You could also bring the bin containing the sequence to a separate editing system, away from the original media.

c. Mount the original high-resolution media. Then select the final sequence and choose CLIP > RELINK. There are a lot of options here, but the important thing is to be sure you select ALL AVAILABLE DRIVES. We’ve provided a sample form at the end of this section to show you what this looks like.

d. Select the sequence which now has High Resolution video in it, and Consolidate (if your format supports it) or Transcode to the single drive designated to hold your final show. Be sure to check SKIP MEDIA IF ALREADY PRESENT ON TARGET DRIVE if you’re consolidating.

e. If using multiple media devices, repeat these steps: Mount the new media, relink, and Consolidate/Transcode until you’re done.

When you attempt to relink to an AMA device, please note that it doesn’t appear as a drive letter in the Relink dialog. However, if you relink to “All Available Drives,” it will relink to a mounted AMA volume—even if the media is on a local drive. To force a relink to media in Avid storage, you must explicitly link to the drive containing that media.
Tips for rezing up

- From the Timeline fast menu, choose CLIP TEXT > RESOLUTIONS. This will display the resolutions attached to each segment in the show as text in the timeline, providing a fast way to see if each shot has been relinked to high resolution.
- From the Timeline fast menu, choose CLIP COLOR > OFFLINE. This will make any segment missing media appear in the color red in your timeline, providing an obvious visual indication of your progress.

- In any bin, you can display all of the clips used in your sequence, so you know what media you need. Select the bin and from the bin menu, choose SET BIN DISPLAY. Then select the SHOW REFERENCE CLIPS checkbox. Your bin will now show every clip used in your sequence. You can also display the Video column to see in what resolution each clip is.

How do I know where my media is located?

One of the easiest ways to make sure you can find the high-resolution media for each clip—before you Transcode any clips to low resolution—is to add the name or location of the media to a column for each clip. To do this, mount the targeted card/disc/Virtual Volume, select all of the clips for that device, and right-click in a column such as DISK LABEL. Choose SET DISC LABEL COLUMN FOR SELECTED CLIPS and enter your media ID so you can find this same Virtual Volume/disc/card when it’s time to reze up.

AMA LINKING VS IMPORTING CLIPS

AMA linking your media vs importing your media - both make the clips available to you for editing, but there are some differences—some obvious, some not. Some of the differences are quite important for your choice of workflow.

- Imported media is stored within the Avid storage file structure and managed using Avid tools
- Imported media lacks some of the metadata present in AMA linked files
- Imported media cannot be batch imported volume-by-volume as AMA clips can; they can only be batch imported file-by-file (except for XDCAM, which can be batch imported from the original disc).

This last point is worth emphasizing. If your workflow involves importing files (instead of AMA linking to them), then an automated Batch Import may not work. An imported file, even if from an XDCAM disc Virtual Volume, is remembered by its file name and location. If either of these things change—such as the file’s location—you may need to manually relink to each file one by one, or in the case of QuickTime location by location.
Alternative to Batch Importing

As we just explained, your Avid editing software will enable you to select an imported clip (or a sequence that uses imported clips) and perform a relink to the currently mounted AMA volumes. This means that if the media for the imported clips is missing or deleted, you can retrieve it by relink to the media rather than Batch Importing. In many cases, since Batch Import would be too time-consuming (clip-by-clip), this provides a good alternative to getting imported media back online. To do this:

1. Mount the AMA volume(s).
2. Relink to the AMA clips as described in the previous section.
3. Transcode or Consolidate the media to your storage.

AMA VOLUMES ON NETWORKS

VOLUMES ON ISIS WORKSPACES

ISIS media servers provide shared storage for multiple users in an editing environment, making collaboration easy. While ISIS workspaces usually store managed Avid media, an ISIS workspace can be used as a location to copy media from field devices into a Virtual Volume.

AMA Virtual Volumes on shared storage are technically supported. They behave as if the Virtual Volumes were on any other hard drive.

In an Interplay environment, this may not be the best way to manage your media if it’s meant to be shared. AMA linked media is treated as local storage—not shared storage. AMA media is not automatically visible to all and is not managed by Interplay Access. Still, in special circumstances, putting AMA Virtual Volumes on ISIS workspaces may be useful.

For example, say you’re at a sporting event with a small storage server at a remote site shooting P2 media. Instead of tying up an editing system to perform ingest, you could copy images of the P2 cards to a folder on a shared workspace in preparation for the edit. The editor would then access this copied material as Virtual Volumes in AMA. He or she could then edit and ultimately consolidate or transcode the final product to Interplay managed storage.

The AMA Virtual Volumes must be on an Interplay workspace or in an Interplay folder that is not monitored by the Media Indexer. AMA files cannot be indexed and shared in the same manner as OP-Atom (Avid format) files can be.
VOLUMES ON NETWORK SHARES

AMA volumes on network shares function as any other hard drive, but performance may vary depending upon the type of network share and network speed. In order for a network share to be seen as a valid media drive, you can type a simple command into the Console window. This can help avoid the possibility of clips showing up as “offline.”

If this happens, try these steps:

1. In your editing software, open the console by choosing TOOLS > CONSOLE from the menu.
2. Click in the text field at the bottom of the Console dialog.
3. Type either `alldrives` or `alldrives 1` (see below) and then click Enter:
   
   a. `alldrives` will allow the network location to function as a media drive for the duration of your session.
   
   b. `alldrives 1` will make this selection persistent between sessions. The setting is stored as a site attribute. Enter the command `alldrives 0` to cancel it and remove the site setting.

MORE SAMPLE AMA WORKFLOWS

To demonstrate how all of the concepts we talked about work together, here are three sample AMA workflows.

Example 1: All-AMA Edit Session

You’re working on a sports program that’s a quick turnaround show—a skiing presentation shot on P2 media (AVC-Intra). The program needs to air merely hours after the ski runs complete—there’s no time to ingest footage from several field cameras before editing, and no spare edit suite to perform the ingest. This workflow is for a standalone environment, and there’s no need for asset sharing among multiple editing workstations.

1. Create a Master folder to house all of the AMA media to be used in the program.
2. As the recordings come in throughout the day, place your AMA Virtual Volumes (copies of your field media) in your Master folder. You can create additional folders to further organize your media for the program. We recommend having no more than 100 Virtual Volumes in one location.
3. If desired, rename the folders that contain your Virtual Volumes. When you link to this media, your folder names can conveniently become the bin names for easier identifying.
4. Be sure that all of the folders in the complete path only contain alphanumeric characters. Using slashes, periods, or any other special characters in any of the folder names may cause AMA to misbehave. Also, if you’re using a Mac, be sure that no two drives/volumes have the same name. This will make it difficult for AMA to find the proper material.

5. Link to this media. Choose FILE > Link To AMA Volume... and navigate to the Master folder.

6. You will be asked how to name the bins that are about to be created. Choose to use “Folder Names” to create bins named after each folder in which you stored your media.

7. Edit your program.

When complete, it’s often a good idea to create a local copy of the media used in the timeline. This enables you to make a simple archive of the show’s media, and allows the Virtual Volumes to be taken offline. To do this:

Select the sequence and Consolidate or Transcode the final sequence to Avid storage.

a. Consolidate the media if you’re using an Avid native codec such as P2

b. Transcode if the sequence uses media supported by an AMA plug-in codec, such as Sony HDCAM SR; you will know if you are because Consolidate will return an error if the source files are not in Avid native format.

Example 2: Editing Offline

AMA transcode workflow

Let’s say you’re working on a reality TV show that uses multiple cameras that constantly shoot full days for several weeks. You’re shooting in AVCHD—a compact format but demanding to edit. Editing is being completed in an ISIS storage environment, but there isn’t enough online storage space for what could end up being thousands of hours of footage.

The decision has been made to transcode the AVCHD to a lower resolution SD format to save server space and allow for more responsive editing. Final programs will then be rezzed up.

Preparation

1. As the field recordings come into the production center, they’re copied to the production backup drives. Two copies are made—one main and one backup. These are your Virtual Volumes.

2. Connect and AMA link to the volumes you wish to Transcode using FILE > Link to AMA Volume...

3. Modify the clip metadata as may be required. You might add a custom column or use the Comments column to enter the source location for the clips—this will be of immense help when conforming back to high resolution later on. You might also choose to batch rename clips.
4. The project format is set to SD. Select the linked clips in a bin and choose CLIP > TRANSCODE. Choose your options in the dialog and transcode to the lower resolution. Repeat for each Virtual Volume.

5. The bins now contain AMA clips and transcoded copies of those same clips. To avoid operational errors, create and name a new bin to hold your transcoded media. Move the transcoded clips into this bin, and close and hide the bins containing the AMA clips. You might want to make a folder in the Project window and place the AMA bins in a folder to make them less visible during editing.

6. Edit your story and then move onto the next “Conforming” stage.

**Conforming**

1. Set the project back to HD. Select the sequence, right-click on it, and choose Modify. Choose to modify the format and then set it back to HD for this sequence.

2. Duplicate your sequence. Create a new bin and place the copy of your sequence in this bin.

3. You want to view every shot in this sequence in the bin, so you can locate each recording you need for the timeline. After activating the bin, choose BIN > SET BIN DISPLAY. Select the SHOW REFERENCE CLIPS checkbox. The full clip for every shot in the sequence will now be shown in the bin.

4. You need to know what sources you need to link to for accessing the original media. Find the column you entered the original source information into for each clip, and Sort by this column.

5. You can now scroll through the list of required Virtual Volumes. Mount these volumes.

6. Select the final sequence and choose CLIP > RELINK. There are many options here; the important thing is to be sure you select ALL AVAILABLE DRIVES.

7. You want to copy the media onto your local storage, so you have a timeline that will play without needing to mount all Virtual Volumes. Select the sequence and consolidate or transcode the final sequence to Avid local storage. Be sure to use Consolidate if the media uses an Avid native codec (such as P2), or Transcode if it’s a plug-in-only codec (such as RED media). You’ll know what you have, because Consolidate will return an error unless the source files are an Avid native format.
Example 3: Choosing Media Using AMA

Using AMA to select what media to edit with

AMA has tremendous value for triaging content that arrives from many sources into the edit suite. Maybe you’re working with a news editor who has an iPhone with video on it and a documentary producer with a GoPro HD Hero memory card with 45 minutes of footage on it. In these cases, you might choose not to ingest all of the content from these devices—instead, you could use AMA to screen all of the available footage and choose only the sections you want to use.

Let's say you need to work with iPhone footage as an example. The phone contains many videos, and you want to preview them all and then select only the best shots for inclusion in your program.

To do this:

1. Connect the iPhone to the same computer as your editing system. On a PC, it mounts as a drive; on a Mac, you'll need third-party software to have the iPhone appear as a drive (such as Phone Disk from www.Macroplant.com).
2. Highlight the bin in which you want the new clips to appear.
3. Choose FILE > Link To AMA Files..., navigate to the file you want to link to, select it, and click OK. You can choose multiple files.
4. The files appear in you selected bin as linked clips. You can now screen the clips and make subclips for any portion of the recordings you wish to copy off the phone.

Since you’re only linked to these files, removing the iPhone will make these clips go offline, so you’ll need to move this footage off of the iPhone and into Avid storage. To do this, use the Transcode command.

1. Right-click on the clips/subclips and choose TRANSCODE.
2. Fill out the dialog and then choose the drive to copy to, the desired resolution, and any other audio options you wish to adjust.
3. Click the TRANSCODE button to begin the copying process.

A copy of the media from the iPhone will be created onto your chosen drive, and new clips will appear in the bin with the same name as the originals, with “.new” appended to that name. This .new clip is not linked to the phone but is linked to the transcoded copies in Avid storage. You may now disconnect the iPhone, delete the linked clips, and edit with these .new copies of the clips, which are now media on your editing system.
AS-02 BUNDLE SUPPORT WITH AMA

An AS-02 “Bundle” is a folder which contains all the elements for a program, or several programs. If multiple programs are included in the bundle, then tracks used in several programs may be stored only once in the bundle, and is shared by the shows. This makes it an efficient way to distribute and archive multiple versions of a program, or multiple programs in a series. “Committing” programs to a bundle has many characteristics in common with burning programs to DVD. You can save and accumulate completed programs in a protected environment.

AS-02 stands for Application Specification 02. It is a specification designed by the Advanced Media Workflow Association (AMWA) with input from many companies, including AVID. You can find more information on the specification at the AMWA website, http://www.amwa.tv.

AS-02 bundles hold a mix of media Essence (video and audio) and other files (captioning, VANC and other). The AS-02 export is for distribution, and so stores flattened files- no multiple video layers or separate edits for each shot. Each full track is a separate essence file. These tracks can use a variety of codecs, from Avid DNxHD codecs to JPEG 2000 for the video. If you create a version and a track is the same in the new version as in an existing version in the bundle, the essence already in the bundle is used instead of saving the same essence a second time.

AS-02 Bundles can be created by Avid editing systems. These bundles follow an industry specification, and so can be created by other programs and systems as well. Avid supports any AS-02 bundle which is compliant with the AMWA specification.

AS-02 SHIM File

It is often important to ensure consistency in our output of final programs, and ensure all program content meets certain criteria- such as using a specific codec for Audio and Video. To assist in this, an AS-02 bundle contains a template file, called a SHIM, which is a description of the specifications the bundle contents will adhere to. When you save a show version to an AS-02 bundle the SHIM ensures the media matches the desired standard by converting the media as required to the codec, frame size, frame rate and other specifications in the SHIM.

It can ensure that all Video is transcoded to the required standard as it is placed into the Bundle. For example, J2K files for one client using their SHIM file, and DNxHD files for another by using a different SHIM file. This allows streamlining of delivery workflows- the SHIM ensures the files in the bundle are appropriate for the delivery, transcoding the video and audio in the program to the SHIM specified target as required.
Program delivery to a client is now often defined in a multipage paper document which the supplier must manually conform their program to. Now, a broadcaster can supply a SHIM file and the program creator can simply place their final show in an AS-02 bundle using the supplied SHIM to ensure compliance.

Avid Editing Systems will now create AS-02 bundles from one or more sequences, and they will also read an external AS-02 bundle via an AMA link.

Your Avid editing application comes with a library of SHIM files. They will be found inside the SupportingFiles folder of the Avid editing application install folder.

**AS-02 BUNDLE CONTENTS**

It’s not necessary to know the structure of a bundle to work with them, but it can help you understand the capabilities of AS-02 if you know what’s inside.

The media in the bundle consists of MXF, OP1a, single essence media files. Each file represents a full track from the program (not individual shots). This means each full Video track and mono audio track is a single file. A Stereo or other Multi Track audio track will also be a single multichannel .MXF file.

A bundle folder contains these objects:

<table>
<thead>
<tr>
<th>ITEM NAME</th>
<th>TYPE</th>
<th>DETAILS</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXTRA</td>
<td>FOLDER</td>
<td>Users can place their own material here, such as scripts, QA reports, Caption files and so on. It also contains a copy of the original Sequence as an .aaf file. If the original (pre-committed) media were available, this sequence would link to it. Being the original program sequence it does carry effects, layers and all the other structures of the edited program. Although it can be imported into a regular Avid bin, it is in the bundle for reference only, and will not link to the bundle media.</td>
</tr>
<tr>
<td>MANIFEST</td>
<td>XML FILE</td>
<td>List of bundle contents</td>
</tr>
<tr>
<td>MEDIA</td>
<td>FOLDER</td>
<td>Contains media files. One single essence MXF file for each track in the show. For as simple 2 audio channel program this would be three files derived from the original program– a Video mixdown and two audio files.</td>
</tr>
<tr>
<td>VERSION</td>
<td>MXF FILE</td>
<td>This is the Sequence in an MXF file (no media) which ties together the essence files in the bundle. There will be one for each version of the program committed to the bundle</td>
</tr>
<tr>
<td>SHIM</td>
<td>XML FILE</td>
<td>Defines and constrains bundle contents.</td>
</tr>
</tbody>
</table>
VOLUME TAB

Inside the Avid, we interact with AS-02 bundles using a new tab in the Project window, the VOLUME tab. This tab behaves much like the BIN tab in that we can create, delete and rename bundles here. Like a bin, the Volume is a part of the project, and is a file in the PROJECT folder with the windows extension .AVV. We don’t need to AMA link to VOLUMES we create in the project, they are a part of the project. We would AMA link to volumes external from the project.

BASIC WORKFLOW

We create an AS-02 Volume in the VOLUME tab, add one or more sequences to it, and then commit the volume. When we commit the volume the video tracks are flattened into a single layer, the media is conformed using the SHIM specification, and we gather this media and all the required metadata for that sequence into the bundle folder.

Once created, we can add other Sequences (versions) to the VOLUME window and commit those additions to the existing bundle to add them to an existing AS-02 volume. We can be confident that the SHIM file will ensure consistency in the media formats between the versions, and that the bundle is as compact as possible because duplicate tracks only appear once in the bundle.

CREATING A VOLUME

Create a Volume using the NEW VOLUME button in the Project window, or the menu item FILE > NEW EXPORT VOLUME. A dialogue will appear in which you supply four pieces of information.

VOLUME TYPE is AS-02. At this time no other Volume types are supported.

DIRECTORY is the folder you wish to commit (store) the bundle into, both media and metadata. Click SET and navigate to the target folder. This name will turn RED if a selected folder has been moved, deleted or renamed.

VOLUME NAME is the name of the final bundle. This becomes the name of the folder holding the bundle.

SHIM NAME points to the SHIM you wish to use. Avid provides a library of SHIM’s in the SupportingFiles folder for your application. You can make a SHIM the default SHIM by creating a folder named DEFAULT inside the AS02_Shim_Templates folder and copying the desired default SHIM inside this folder.
Click OK and a new Export Volume is created in the VOLUME tab.

A new window which looks similar to a BIN is also created- this is the VOLUME window for the bundle. It has many characteristics of a bin – for example you can show and hide columns of information using BIN > CHOOSE COLUMNS. It is also different in that there is a row of controls at the top which are specific to a volume.

It has some special buttons at the top, and at the left is clearly labelled as an Export Volume. There are three buttons here:

- **Set** Choose the location for the bundle
  - Calls up original Export Volume window, so you can change any of the bundle attributes like the SHIM, location or Volume Name. This only works until you commit the volume, after which these settings are fixed.
  - COMMIT button writes Volume contents to the chosen folder location
ADDING YOUR FIRST SEQUENCE

AS-02 bundles are for edited programs. You may only add Sequences to a Volume. While after committing you will see clip icons for the accompanying media, these are Volume Clips, containing only Video or Audio, and representing full tracks from the timeline. They are created when you commit the volume and are not really classic clips. They would be difficult to edit with as Video and Audio are separate clips.

Drag a Sequence from a bin and drop it into the Volume window. A copy of the sequence is created in the Volume window. It has a yellow dot, indicating it has not yet been committed.

In the EXPORT VOLUME window, click the COMMIT button to create the AS-02 Bundle. The SHIM is applied, the video and audio are processed, and a folder with all your objects in it is created at the target location. This is the AS-02 Bundle.

Below we see the results of a COMMIT operation in your Export Volume window. A new Video track and 4 new audio tracks have been created from this Sequence. At your export location a folder containing your AS-02 bundle elements has been created with contents as shown here.

The 5 MXF media files in the bundle are one for each track in the committed sequence. Each track is a mixdown of the original. The multiple video layers are flattened into a single video layer.

The Video and Audio you see in the VOLUME window are NOT in the AVID MEDIAFILES folder, but are in the AS-02 Bundle you just created. This is where AMA comes in - if you wish to access someone else’s AS-02 bundle Sequences or Tracks you need to AMA link to their AS-02 Bundle.
MODIFYING THE EXPORT VOLUME

Before the Export Volume is committed, you can modify its contents, remove sequences, and select a new SHIM, directory and other attributes. Once a volume is committed you cannot do any of these things with committed contents.

You can however add more Sequences to a committed volume. Drag new sequences into the Volume, and their MEDIA STATUS will be yellow. Press the commit button, and they will be added to the AS-02 Bundle which already exists. Their MEDIA STATUS will turn to green. Any tracks which are the same as existing sequences will not be copied again, but will share the essence for sequences already in the bundle.

WORKING WITH A COMMITTED VOLUME

The contents of a volume cannot be changed once it is committed, except for adding more sequences to the volume. You can however load the single essence files (either Video or Audio) and screen and edit from them.

The committed sequences are protected and cannot be loaded into the record monitor so that you cannot change an AS-02 bundle timeline by accident. If you try to load a sequence into the Record monitor a dialogue will appear offering to make a duplicate of the sequence in one of your bins. You can work with this duplicate. To avoid the warning, just drag and drop the Sequences from the Export Volume into a bin, in which case a duplicate is made automatically.

Remember if you want the original unflattened sequence, it is provided for reference in the AS-02 bundle in the extra folder, although the media for this original sequence is not in the bundle.

AMA LINKING TO AS-02 VOLUMES

To access the contents of an existing AS-02 bundle, we use a menu item FILE > LINK TO VOLUME FOR EXPORT. Select this option, and then navigate to and select the Bundle folder. A new Export Volume will appear in your projects Volume tab. It will contain one or more Sequences, as well as all the clips for the tracks required by these sequences.

While technically individual Clips may be loaded and used for editing, it would be far better to work from a copy of the bundle Sequence. The individual clips are either Video or Audio tracks only, whereas in the bundle sequence the Video and Audio are present in-sync with each other.
**AS-02 Workflow Example**

You create an English commercial and store it in an Expert Volume. At a later date, a new language version is required, and you are sent a new stereo mix in Spanish. This is to be laid against the same picture used in the English version.

- AMA Link to the AS-02 Bundle with the original English commercial in it.
- Drag the English version from the Export Volume window into a new bin.
- Recut this to create the Spanish version – add the new audio track
- Drag and drop this completed Spanish commercial into the Export Volume window. Press the COMMIT button. The bundle will now include the Spanish mixed version

**TROUBLESHOOTING AMA**

When things go wrong with AMA linking, there is usually a pretty simple reason. Here are some common troubleshooting tips to use when AMA doesn’t function as expected.

**Volume won’t Automatically AMA-Link: Is this feature turned on?**

Look in your AMA settings, on the third tab. The middle option **Automatically AMA-link to Volumes** should be turned checked

**Are the correct plugins installed?**

Missing a required plug-in is a very common occurrence. All AMA plug-ins—except for QuickTime, MXF, Sphere and AS-02 —require manual installation. It’s entirely possible that a system has been set up without having all of the plug-ins you need installed. To see which plug-ins are present, go to the console and type in `ama_listplugins` to print out an AMA report. Be sure that your required plug-ins are listed here.

Please note that there are 32-bit plug-ins (for pre-Media Composer/Symphony 6 and pre-NewsCutter 10 software) and 64-bit plug-ins (for Media Composer/Symphony 6 and NewsCutter 10 and higher software). Be sure you have the correct version installed for your software. You’ll find links to all of the AMA plug-ins available at WWW.AVID.COM/AMA.
Is the folder structure correct?

Sometimes when you copy the contents of a media volume from a device, an important folder may be missing. For example, copying the contents of a BPAV folder without copying the BPAV folder itself will create a Virtual Volume that cannot be linked to. In this case, the solution is simple; create a folder named BPAV and put the media copy inside of this folder.

When copying from original media to create a Virtual Volume, consider the volume file structure as unchangeable. We never copy just some of the folders in a volume, always copy every folder and file to create an exact image of the original recording. Failing to do this can break Volume Mounting.

Are the metadata files missing?

This is another example of not copying the entire contents of a volume. XDCAM discs contain several XML files, which are essential for proper operation of XDCAM, as well as for AMA linking.

If someone copied a media volume without including what he or she thought were unneeded files, then Virtual Volume linking will not work. You’ll need to recover the missing files from the original media. If this media is no longer available, all may not be lost. In some formats, linking to a file may make the media accessible (XDCAM, for example). In others, the files exist as separate entities for video, audio, and data, and manual file linking will be ineffective (with XDCAM-EX, for example) and you must recover the entire volume.

Did you just delete the AMA clips?

If you deleted any AMA clips that are in use, the media in the timeline will be offline. You can correct this by closing the sequence bin and opening it again. In general, do not delete AMA clips while they are in use.

Are you using AMA linking correctly?

If you or someone else isn’t experienced with AMA, you might try to link using an incorrect method, linking to the wrong folder, wrong files, or just using the wrong linking method for a given situation. Operator unfamiliarity may appear to cause problems.

For example, XDCAM-EX supports Link to AMA Volume... The XDCAM-EX clips are stored as a collection of separate video, audio, and data files in a folder labelled CLIPR. Using Link to AMA File(s)... to try linking to just one of these files would serve no useful purpose, so it’s not supported.

Do not assign a source name

If you change the source names of clips after you consolidate or transcode them, they will not relink to the original AMA media. If you want to modify a data column to hold the name of the original source location, consider using the Comments or Disc Label columns instead.
AMA clips show as being offline

Try closing and reopening the bin. This often causes a re-indexing of the clips, and they may appear online again.

You can’t write to the drive

Devices such as P2 card readers can mount on your computer as hard drives without first installing any driver software. However, to applications such as your Avid editing software, these devices might look like regular drives and not like, say, a P2 device. Because of this, operations such as EXPORT TO DEVICE might not work, even though you can see your device as a hard drive on your desktop. To fix this, install the required drivers so that your software can properly identify the device for full functionality.

Every time media is mounted, a new duplicate bin is created

You’re using P2 media and each time you insert a card into the reader, a new bin is created for its clips, even though you’ve used the card previously, and the clips already exist in the project.

There are two resolutions. One is to turn off the option for rescanning the media, in your AMA settings. The other is to make sure you scan the clips initially using the option to “Create a new bin using [volume name].” As long as you don’t rename the original bin, AMA will link the remounted card to its original bin and not create a new one.

AMA errors: Check in the console

The Avid Console is a window in which your Avid software posts messages as it operates. This window is not meant for normal operator use, however, the messages in the console can be useful for problem-solving.

In your editing application, choose TOOLS > CONSOLE to open the console. As you attempt to link using AMA, messages here may give you an indication of any issues that occur. Here’s a sample bit of console dialog we got when we attempted to link to a missing .mov file:

```
------- AMA Link To File(s) -------
[ Plugin Name = QuickTime Plug-In Avid Technology, Inc. Version = 1.2 ]
processed C:\Users\Paul Sampson\Desktop\© LMOP_example.mov
AMA: Unlinked © LMOP_example due to missing file on disk
```
AMA errors: Look in the Log file

If the error is no longer displayed in the console, or you want more information about an error, you can consult a Log file, which tracks AMA errors. This file will indicate some common errors—such as an invalid file name or a corrupt file. Here’s where to find the Log file on a PC and a Mac:

PC  C:\Users\Public\Documents\Avid Media Composer\Avid FatalErrorReports
MAC  Volume/Users/Shared/AvidMediaComposer/Avid FatalError Reports

The name of the log file is AMALoggerYYYYMMDD.log, where the “YYYYMMDD” will be a date variable such as AMALogger20111231.log

MISCELLANEOUS

Here’s a collection of features that can be useful as you use AMA.

Clip Color: This can be used to show all SD clips as a mustard color in an HD project, or vice-versa. It’s a good way to monitor the progress of your “rez up” as you watch the mustard clips change back to their normal color. From the Timeline fast menu, choose “Clip Color” and turn the SD/HD option to “On.”

8 Audio Tracks: per clip can be difficult to deal with, and with a format like XDCAM HD 50 Mbit is the default based on the SMPTE spec. Each time you load the clips for editing, it will auto-create the extra audio tracks, creating tracks you do not need. To save you the work of having to turn the source audio tracks off each time to avoid this, on a Media Composer go to the Composer settings, select the EDIT tab, and disable AUTO CREATE NEW TRACKS.

Modify AMA resolutions: With XDCAM, if you need to see an AMA clip in your bin at a different resolution than what is currently displayed, this is possible. You can right-click on one or more AMA clips and choose “Modify AMA Resolutions.” Make selections as appropriate, but be sure that the original media is available to make the switch. For XDCAM Virtual Volumes, this means you’ll need to have copied the PROAV folder from the disc, which will double the size of your Virtual Volume!

Stopping media from AMA linking: Each time you connect new media, AMA will attempt to link it. Sometimes, you may just want to check a disc or card in the deck and not want the relink to occur in your editing software. In the case of XDCAM, relinking unnecessarily could waste several minutes. To work around this, close the project (do not exit the program) and connect the media. Since no project is open, the media will not link, and you can check to see if it is the correct media, use software tools to rename the media, and so on.
APPENDIX A: NATIVE AND NON-NATIVE CODECS

We have been referring to native and non-native Avid codecs throughout this document. It’s clear that, depending on the codec, certain capabilities exist for working with that footage. “Native” codec support refers to a device that can work directly with the encoded data; it can be copied more quickly into video storage and is easier for Avid systems to work with.

The chart on the following page identifies which codecs are native and which are not, as well as outlines what is possible with each codec.
## Codec is not natively supported

<table>
<thead>
<tr>
<th>Format</th>
<th>Can consolidate?</th>
<th>Can render this format?</th>
<th>Can transcode?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVCHD</td>
<td>x</td>
<td>x</td>
<td>yes</td>
</tr>
<tr>
<td>Canon .mov</td>
<td>x</td>
<td>x</td>
<td>yes</td>
</tr>
<tr>
<td>HDCAM SR</td>
<td>x</td>
<td>x</td>
<td>yes</td>
</tr>
<tr>
<td>QuickTime</td>
<td>x</td>
<td>x</td>
<td>yes</td>
</tr>
<tr>
<td>(some cases *)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RED</td>
<td>x</td>
<td>x</td>
<td>yes</td>
</tr>
</tbody>
</table>

## Codec is natively supported

<table>
<thead>
<tr>
<th>Format</th>
<th>Can consolidate?</th>
<th>Can render this format?</th>
<th>Can transcode?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arri Alexa</td>
<td>yes</td>
<td>DNxHD</td>
<td>yes</td>
</tr>
<tr>
<td>Canon XF</td>
<td>yes</td>
<td>XDCAM</td>
<td>yes</td>
</tr>
<tr>
<td>GFCAM MXF</td>
<td>yes</td>
<td>XDCAM</td>
<td>yes</td>
</tr>
<tr>
<td>P2</td>
<td>yes</td>
<td>AVC-Intra</td>
<td>yes</td>
</tr>
<tr>
<td>ProRes (on a PC **)</td>
<td>yes</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>QuickTime ProRes (on a Mac **)</td>
<td>yes</td>
<td>ProRes</td>
<td>yes</td>
</tr>
<tr>
<td>QuickTime</td>
<td>yes</td>
<td>various</td>
<td>yes</td>
</tr>
<tr>
<td>(some cases *)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>XDCAM HD</td>
<td>yes</td>
<td>XDCAM</td>
<td>yes</td>
</tr>
<tr>
<td>XDCAM IMX</td>
<td>yes</td>
<td>MPEG</td>
<td>yes</td>
</tr>
<tr>
<td>XDCAM DV</td>
<td>yes</td>
<td>DV</td>
<td>yes</td>
</tr>
<tr>
<td>XDCAM EX</td>
<td>yes</td>
<td>XDCAM EX 35 Mbits</td>
<td>yes</td>
</tr>
</tbody>
</table>

* A QuickTime file that uses an Avid native codec, such as DNxHD, can be consolidated, transcoded, and rendered. A QuickTime file using a non-native codec, such as the Canon QuickTime codec, can be transcoded only.

** ProRes media cannot be included in an AAF as either embedded or consolidated media.
APPENDIX B: TERMS DEFINED

Avid MediaFiles Folder

The location on your media drive where your Avid editing software stores the media files it captures, imports, renders, and transcodes.

This folder holds MXF OP-Atom media only—separate video and audio files for each recording. The video media can use any of the Avid native codecs, including all of the DNxHD codecs, and the Avid compression ratio codecs (2:1 and so on). Some AMA media also use Avid native codecs, such as XDCAM, P2, Canon XF, GFCAM, and ProRes. AMA files of this type may be consolidated (copied) into this folder after they are AMA linked.

Once media is placed in this folder, it becomes “managed” by your editing application. You can use system-level tools such as the Media Tool, or tools in a shared environment such as Avid Access, to manage this media. Material is added to or removed from this folder by your software; you should never go here to manually manipulate media.

Capture

The process of converting an incoming baseband video and audio signal into Avid native format files and storing them in the Avid MediaFiles folder of a media drive.

For legacy formats, your Avid editing software can still capture from video tape and, in many situations, capture live video from a studio or satellite feed. To perform a capture, you need an I/O (Input/Output) interface such as Avid Nitris® DX, Mojo DX, or a third-party interface from any Avid Open I/O partner (such as AJA, Blackmagic Design, Bluefish444, Matrox, or MOTU).

Codec

Codec is a blending together of two terms—compression and decompression. When a video or audio signal is captured, it’s coded into a file and generally reduced in size with an algorithm. On playback, it’s decoded back to video or audio.

There are many ways to do this, and different codecs work in different ways. Some are chosen for quality, and some for their ability to make a file of a compact size.

Many codecs are not suitable for editing due to the nature of the compression algorithm they use. Some codecs require intensive computing power for real-time playback, such as AVCHD.

DNxHD, HDCAM SR, XDCAM HD 50Mb, DV, H.264, and MPEG are all video codecs. MP3, PCM, and AC3 are audio codecs.
**Container Format or Wrapper**

The file that is coded when material is captured (see above) is packaged inside of a container. This container includes instructions that tell the software how to open the file. For example, QuickTime is a container that may hold material that has been encoded to DNxHD, H.264, or ProRes, among others. Even if the player can open the file, the codec must be present in the system in order for the file to play back. This is why some video files play back in some players and not in others—and why you need to have the right codec installed in order to play back the file.

Consider, as an example, a DNxHD video recording and its accompanying PCM audio. These are termed the essence of the file. They can be packaged in several different ways for screening and distribution. You can export using the “Same As Source” option from your Avid editing system to a QuickTime file. In this case, the same video and audio is now “packaged” in a container—the QuickTime .mov file. QuickTime movies can use many different codecs; it is merely the container the essence travels in. Other container formats include MXF, WMV, AVI MP4, and AIFF files.

**Consolidate**

This copies media into the Avid MediaFiles folders. With some formats that your Avid software supports natively, you can consolidate AMA linked files directly into Avid storage as well. This is done by “rewrapping” the contents of the file into a different (MXF) container. Consolidate creates a file copy, and there is no loss of quality.

Consolidate only works for media that is in a format your Avid editing software understands natively. This is why some AMA linked volumes will consolidate (such as XDCAM) and some will not (AVCHD, for example).

**Format**

Format is commonly used to describe several different things. In the context of this AMA discussion, it most often refers to the contents of the Format column you can display in a bin, which would show information such as “HD 1080i/59.94” for a clip. This describes the video frame size, frame rate, and field motion for the clip.

**Import**

The process of moving a file from the outside world into the Avid MediaFiles folder. You can import video movies, still images, and audio files of various types.

Often, an external file may not be in the proper container (MXF), doesn’t use an Avid native codec, is the wrong frame size, or has other discrepancies that make it unacceptable for Avid storage. In these cases, the file will need to be converted on import into a format of your choosing.
If the file is correct, if it’s an Avid native file in all respects (except the container), then the transfer requires no reprocessing and becomes, in effect, a file copy. We say these files are being “rewrapped” upon import, and this process happens quickly. The import is much faster and referred to as a Fast Import. When one is in progress, your import dialog screen will indicate this—as well as the speedy progress bar!

**Link**

Linking to a volume using AMA creates clips in a bin for all of the recordings on the volume, making them accessible for editing and transcoding. If the linked files are in an Avid native format, they can also be consolidated in that format.

Linking to a file using AMA creates a clip for that one file in the selected bin.

File linking does not work for all formats. File linking works with formats such as P2, XDCAM, and QuickTime movies, where the video and audio are all contained in a single file. File linking does not work with formats such as XDCAM EX and Canon XF video. These formats present their recordings as separate video and audio files with accompanying descriptive files. Even if you could file link to any one of these individual files, they would be difficult to work with. You can access the contents of these recordings by volume linking.

**Native Formats**

These are the media types that can be stored in the Avid MediaFiles folder. Additionally, these formats can be consolidated, transcoded, and rendered. MXF wrapped P2, XDCAM, ProRes, and GFCAM are examples of native formats. See the Format table presented in the previous section.

Non-Native Formats These are formats that cannot be stored in the Avid MediaFiles folder directly. These formats do not show as options for rendering, and you cannot copy—consolidate—these files into your Avid storage. You can, however, convert them upon import or, in some cases, link to them and transcoded them to Avid storage. Examples of non-native formats include AVCHD, RED, and HDCAM SR.

**Resolution**

Resolution refers to the physical size of the visual frame. Full HD is 1920 x 1080 pixels in size, NTSC broadcast video is 720 x 486, and PAL broadcast video is 720 x 576 pixels.

In some cases, resolution refers to the level of detail available in the image data—a more compressed image is said to have lower resolution. A larger image area and greater image detail provide the possibility of higher quality pictures, but do not guarantee it. Other factors, such as the amount of compression, are also factors in overall quality—not just frame size.
**Transcode**

Transcode means to convert from one codec or standard to another. Transcodes take place when converting PAL to NTSC or H.264 to DNxHD, for example.

It's also a copy command for moving media into the Avid MediaFiles folder. During the copy, the media is converted from one codec to another. This process is minimally lossy, if you disregard a quality loss that may be a result of going to a lower quality codec.

Some AMA-linked media like AVCHD cannot be moved (consolidated) into Avid storage. It needs to be transcoded into Avid storage, in which case, it is converted into an Avid compliant MXF file, which uses an Avid native codec.

**Virtual Volume**

A copy of the recording from an external recording device. For example, the contents of a P2 card can be copied into a folder on a local hard drive.

Using the Avid AMA commands, you can link to this content to screen and edit with it.

Your other options for accessing content on a Virtual Volume include importing, transcoding, and consolidating with this P2 media. See the accompanying chart for the capabilities when using other formats.